Bilder Upload
Follow Me!
#1

kann LCD4Bit_mod nicht installieren

in Einsteiger 11.05.2012 02:14
von Gast
avatar

Hallo,
ich habe zu meinem neuen Arduino-Uno ein LCD-Keypad-Shield und wollte die auf der Site des Lieferanten (komputer.de) gefundene Library installieren.
Leider ist die Dateianordnung bei mir ganz anders als in der Readme-Datei beschrieben. Ich habe daher die entpackten Files nicht nur in das Verzeichnis ...../libraries kopiert, sondern nacheinander an weitere Stellen. Ich finde dies unbefriedigent und es funktioniert auch nicht. Wenn ich import library anklicke, wird nichts gefunden.
Vielleicht kann ein Experte einem Arduino-Anfänger helfen?

In der Readme-Datei steht:
To install this library, just place this entire folder as a subfolder in your
Arduino/lib/targets/libraries folder. ---- >>>> den Ordner gibt es bei mir nicht!

When installed, this library should look like:

arduino-0010/hardware/libraries/LCD4Bit_mod (this library's folder)
arduino-0010/hardware/libraries/LCD4Bit_mod/LCD4Bit_mod.cpp (the library implementation file)
arduino-0010/hardware/libraries/LCD4Bit_mod/LCD4Bit_mod.h (the library description file)
arduino-0010/hardware/libraries/LCD4Bit_mod/keywords.txt (the syntax coloring file)
arduino-0010/hardware/libraries/LCD4Bit_mod/examples (the examples in the "open" menu)
arduino-0010/hardware/libraries/LCD4Bit_mod/readme.txt (this file)

In meiner Arduino-1.0-Installation ist libraries kein Unterverzeichnis von hardware. Im Verzeichnis hardware kommt man erst über arduino, cores, arduino in ein Verzeichnis, wo libraries des LCD hinpassen.


Ach ja, die Liste der Fehlermeldungen fängt so an:
C:\Progr-MCU\Arduino_10\arduino-1.0\libraries\LCD4Bit_mod\LCD4Bit_mod.cpp:29:57: error: WConstants.h: No such file or directory
C:\Progr-MCU\Arduino_10\arduino-1.0\libraries\LCD4Bit_mod\LCD4Bit_mod.cpp: In member function 'void LCD4Bit_mod::pulseEnablePin()':
C:\Progr-MCU\Arduino_10\arduino-1.0\libraries\LCD4Bit_mod\LCD4Bit_mod.cpp:58: error: 'LOW' was not declared in this scope
C:\Progr-MCU\Arduino_10\arduino-1.0\libraries\LCD4Bit_mod\LCD4Bit_mod.cpp:58: error: 'digitalWrite' was not declared in this scope
C:\Progr-MCU\Arduino_10\arduino-1.0\libraries\LCD4Bit_mod\LCD4Bit_mod.cpp:59: error: 'delayMicroseconds' was not declared in this scope
C:\Progr-MCU\Arduino_10\arduino-1.0\libraries\LCD4Bit_mod\LCD4Bit_mod.cpp:61: error: 'HIGH' was not declared in this scope

Es wäre nett, wenn m ir jemand helfen würde.
mfg
kpc / Gast

nach oben springen

#2

RE: kann LCD4Bit_mod nicht installieren

in Einsteiger 12.05.2012 18:46
von gast
avatar

Problem gelöst!
Man darf nicht die neue IDE benutzen, sondern, z.B. arduino-0022

nach oben springen


Besucher
0 Mitglieder und 1 Gast sind Online

Wir begrüßen unser neuestes Mitglied: hobbit23
Forum Statistiken
Das Forum hat 110 Themen und 181 Beiträge.

Xobor Forum Software von Xobor.de
Einfach ein Forum erstellen